Thursday, November 5, 2009

Adobe Presenter Embedded swf appears choppy or twitchy


When embedding a swf animation into adobe presenter, the final movie apears twitchy or 'stuttering'. This occurs because the "Control using presentation playbar" option is selected, and Presenter is doing odd playback control on your swf.

Basically, to keep the slide time synched with your swf time, it is either jumping ahead or backwards to keep them together, not ideal at all!


1. Rob Rodes:

I did not find this solution to work for me, but it might for you, it's pretty low effort to try and if it works great!

2. My Solution:

First I cut all of my main timeline and chucked it into a movieclip which then got thrown on frame 1 layer 1 of the main stage (make sure the main timeline is the same length as the new movieclip timeline), we'll name the new movieclip "allAnimations".

Now, the playback bar for presenter won't have access to this movieclip, so the stuttering effect is gone, but what if the user is jumping back and forward, how do we sync this animation up with the main timeline?

Here's the magic (Actionscript 2.0):

allAnimations.onEnterFrame = function()
if(this._currentFrame - this._parent._currentframe > 150)
else if(this._parent._currentframe - this._currentFrame > 150)

Basically if the animation's timeline differs from the main timeline by more than 5 seconds then sync them up!

This is a hack, i'm positive there is an unfound better solution, but for now this may work for you, if so enjoy!


  1. I tried both solution but it didn't work with me!!

    I just want to make sure about what i am doing here: where shall i insert the action script code? on the first frame on the time line? or on the movie clip? or am i just lost!

  2. First frame of your fla, and on that first frame you have a movie clip named allAnimations.

    Feel free to contact me with your source and I'll take a closer look for you.

  3. It's still not working with me :(
    I tryied that soo many times in different swf files!

    when i use the simple swf animation (30 fps - 150 frames) and the slide time is 5 seconds. it plays fine but when using the "Control using presentation playbar" it will jump !!

    reducing the timeline wont do any different for me !!

    and the second solution: putting all my animation in a movieclip "allAnimations" and inserting the action script code wont play the playback! so i dont have access to go back or stop the animation in the adobe presenter!

    I dunnu what shall I do ?!

    shall i convert my SWF to a movie !?

  4. Did anyone ever find a solutions for this?? This program/plugin SUCKS!!!